Domain Manage

how to switch off error_log in WHM

Discussion in 'General Board' started by fish, Sep 20, 2011.

Thread Status:
Not open for further replies.
  1. fish United Kingdom

    fish Well-Known Member

    Joined:
    Nov 2006
    Posts:
    2,725
    Likes Received:
    27
    Does anyone know what service/where to look in order to stop error_log being generated on each of my sites? (or for them to auto delete after a certain time/size limit, is that poss?)

    The combined size of all my sites error logs are unnecessarily huge ...

    TIA

    Fish
     
  2. Domain Forum

    Acorn Domains Elite Member

    Joined:
    1999
    Messages:
    Many
    Likes Received:
    Lots
     
  3. monaghan United Kingdom

    monaghan Moderator Staff Member

    Joined:
    May 2007
    Posts:
    1,993
    Likes Received:
    45
    I don't think you can control the sizes from WHM. You could look at manually generating some logrotate rules for these error logs.

    In the PHP configuration (under service config), you can switch into advanced mode and have more control over error handling (even switching off logging completely), however, if you don't log anything then finding future problems will be difficult.

    What's generating so many errors?

    First stop in my mind would be to address the processes that are causing the errors and resolve these so you only have genuine errors logged.
     
  4. fish United Kingdom

    fish Well-Known Member

    Joined:
    Nov 2006
    Posts:
    2,725
    Likes Received:
    27
    Hi Alex,

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-

    seems to be a very popular entry!

    any ideas ?
     
  5. monaghan United Kingdom

    monaghan Moderator Staff Member

    Joined:
    May 2007
    Posts:
    1,993
    Likes Received:
    45
  6. fish United Kingdom

    fish Well-Known Member

    Joined:
    Nov 2006
    Posts:
    2,725
    Likes Received:
    27
  7. jimm United Kingdom

    jimm Active Member

    Joined:
    Feb 2008
    Posts:
    688
    Likes Received:
    13
    Indeed the first step should be to solve the errors but failing that log size rotation can be found in the tweak setting part (provided you are on 11.30 onwards).
     
  8. expertc

    expertc Well-Known Member

    Joined:
    Apr 2009
    Posts:
    1,009
    Likes Received:
    16
    +1 about checking why it is so large. Deleting - you can set the size limit (as suggested above) or even set a cron job to delete the file every 1 hour or so...
     
  9. monaghan United Kingdom

    monaghan Moderator Staff Member

    Joined:
    May 2007
    Posts:
    1,993
    Likes Received:
    45
    I didn't think the WHM log rotate hit the individual domain logs, isn't it just the system logs?
     
  10. fish United Kingdom

    fish Well-Known Member

    Joined:
    Nov 2006
    Posts:
    2,725
    Likes Received:
    27
    Just checked a few of the sites error logs and there's been none generated today, so whilst this is the culprit:

    [20-Sep-2011 17:45:56] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/: cannot read file data: Is a directory in Unknown on line 0

    turning off repeat error logging in PHP Configuration Editor has stopped the files growing hour by hour, day by day but of course not resolved the error repeating itself (however the sites run ok)
     
  11. monaghan United Kingdom

    monaghan Moderator Staff Member

    Joined:
    May 2007
    Posts:
    1,993
    Likes Received:
    45
    You should still address the issue though as it will hurt your performance if the system is having to handle errors on each page load.

    Happy to take a look tomorrow morning if you want. (you'll need to remind be of the root password)
     
  12. fish United Kingdom

    fish Well-Known Member

    Joined:
    Nov 2006
    Posts:
    2,725
    Likes Received:
    27
    Cheers Alex, have sent you an email.
     
Thread Status:
Not open for further replies.

Share This Page